Uncaught PharException: zlib extension is required for gz compressed .phar file

I downloaded Symfony and got this error. I rushed to build a new PHP, but that wasn’t the solution.

The fix was to edit the php/extensions.ini file, and add the extension to use zlib.


PHP doesn’t use the libraries directly. It uses an extension (a PECL extension), which may be loaded dynamically, to provide the glue and PHP functions to make calls to the shared library.

See: Same question at stackexchage

Leave a Reply